CHAPTER 4
BLOOD GLUCOSE METER
4.1. Introduction

Glucose is one of the body’s main sources of energy. In normal physiology, the body maintains Blood Glucose levels within a narrow range (70-130mg/dl). Blood Glucose is balanced between endogenous appearance from the liver (through glycogenolysis and gluconeogenesis) and kidneys, exogenous appearance from the intestines (following a meal), and utilization of glucose by all tissues. Two gross metabolic conditions exist. When fasting, the body relies primarily on glucose stored in the form of glycogen and fatty acids stored in the form of triglycerides to fuel its metabolic needs. After a meal, glucose absorbed from the gut is used to replenish glycogen and fat stores diminished while fasting.

The body regulates the processes that control the production and storage of glucose by secreting the endocrine hormone of insulin from the pancreatic B-cells. Insulin facilitates anabolic metabolism throughout the body as presented in Table 4.1. An increase in insulin above basal concentrations (2-12 mU/l) will decrease the release of glucose from the liver and increase glucose uptake into insulin-receptive tissues. This has the net effect of decreasing endogenous Blood Glucose appearance [1]. There are many substances in the body that promote and inhibit insulin secretion, refining the detail to which the B-cells react to changes in the body’s metabolic state. Glucose is by far the dominant stimulus for insulin secretion, establishing a direct relationship between insulin secretion and the Blood Glucose level in the body. When glucose concentrations increase, insulin concentrations will increase as well and a classical negative feedback system that keeps glycemia within very narrow range.
Table 4.1: Anabolic effects of insulin

<table>
<thead>
<tr>
<th>Tissue</th>
<th>Anabolic Effects</th>
</tr>
</thead>
<tbody>
<tr>
<td>Liver</td>
<td>Glucose uptake and storage increased</td>
</tr>
<tr>
<td></td>
<td>- Glycogen synthesis increased</td>
</tr>
<tr>
<td></td>
<td>- Gluconeogenesis decreased</td>
</tr>
<tr>
<td>Muscle</td>
<td>Protein synthesis increased</td>
</tr>
<tr>
<td></td>
<td>- Amino acid transport increased</td>
</tr>
<tr>
<td></td>
<td>- Protein synthesis increased</td>
</tr>
<tr>
<td></td>
<td>Glycogen synthesis increased</td>
</tr>
<tr>
<td></td>
<td>- Glucose transport increased</td>
</tr>
<tr>
<td></td>
<td>- Glycogen synthase activity increased</td>
</tr>
<tr>
<td></td>
<td>- Phosphorylase activity decreased</td>
</tr>
<tr>
<td>Adipose</td>
<td>Triglyceride storage increased</td>
</tr>
<tr>
<td></td>
<td>- Lipoprotein lipase activated</td>
</tr>
<tr>
<td></td>
<td>- Triglyceride hydrolysis increased</td>
</tr>
<tr>
<td></td>
<td>- Glucose transport increased</td>
</tr>
<tr>
<td></td>
<td>- Intracellular lipase inhibited</td>
</tr>
</tbody>
</table>

The term diabetes is derived from the Greek word that means, “passing through (urine)” and the word mellitus is derived from Latin, which means, “honey”. Diabetes mellitus means, literally, honey-sweet urine.

Diabetes mellitus [2] is a condition in which the pancreas no longer produces enough insulin or when cells stop responding to the insulin that is produced, so that glucose in the blood cannot be absorbed into the cells of the body. Symptoms include frequent urination, lethargy, excessive thirst and hunger. The treatment includes changes in diet, oral medications and in some cases daily injections of insulin.
Diabetes mellitus is a chronic disease that causes serious health complications including renal (kidney) failure, heart disease, stroke, and blindness. Approximately 14 million Indians (about 5% of the population) have diabetes. Unfortunately, as many as one-half are unaware that they have it.

Diabetes mellitus is a term applied to a number of conditions or syndromes that in untreated state are characterized by hyperglycaemia [3], [4]. It is a disorder of metabolism of carbohydrate, fat and protein associated with a relative or absolute insufficiency of insulin secretion and with various degrees of insulin resistance. Insulin is a hormone that is produced in the beta cells of the pancreatic islets of Langerhans. Its role is two fold, firstly to enhance the entry of glucose into the liver, muscle and adipose tissue, and secondly to promote storage of energy substrate in the form of glycogen, fat and protein thus resulting in a lowering of the Blood Glucose concentration [5]. It is very important to keep Blood Glucose concentrations within a narrow range of 3 to 10mM both under conditions where the patient has been fed or has been fasting. Blood Glucose concentrations less than 3mM (hypoglycaemia) impair brain function, whereas glucose concentrations higher than 10mM (hyperglycaemia) exceed the renal glucose reabsorption threshold, which results in wasting of glucose. In addition, protracted hyperglycaemia causes degenerative complications in the long-term.

Every cell in the human body needs energy in order to function. The body's primary energy source is glucose, a simple sugar resulting from the digestion of foods containing carbohydrates (sugars and starches). Glucose from the digested food circulates in the blood as a ready energy source for any cells that need it. Insulin is a hormone or chemical produced by cells in the pancreas, an organ located behind the stomach. Insulin bonds to a receptor site on the outside of cell and acts like a key to open a doorway into the cell through which glucose can enter. Some of the glucose can be converted to concentrated energy sources like glycogen or
fatty acids and saved for later use. When there is not enough insulin produced or when the doorway no longer recognizes the insulin key, glucose stays in the blood rather entering the cells.

The body will attempt to dilute the high level of glucose in the blood, a condition called hyperglycemia, by drawing water out of the cells and into the bloodstream in an effort to dilute the sugar and excrete it in the urine. It is not unusual for people with undiagnosed diabetes to be constantly thirsty, drink large quantities of water, and urinate frequently as their bodies try to get rid of the extra glucose. This creates high levels of glucose in the urine.

At the same time that the body is trying to get rid of glucose from the blood, the cells are starving for glucose and sending signals to the body to eat more food, thus making patients extremely hungry. To provide energy for the starving cells, the body also tries to convert fats and proteins to glucose. The breakdown of fats and proteins for energy causes acid compounds called ketones to form in the blood. Ketones will also be excreted in the urine. As ketones build up in the blood, a condition called ketoacidosis can occur. This condition can be life threatening if left untreated, leading to coma and death.

Types of diabetes mellitus

“Type I” indicates the process of beta-cell destruction that may lead to DM. It accounts for 5-10% of the subjects with DM and the rate of beta cell destruction varies from individual to individual [6]. The rapidly progressing form of TID is common amongst children but may also be seen in adults [7]. Whereas, the slowly progressive form of TID is reported to occur mainly only in adults where it is also known as “Latent autoimmune diabetes in adults”. The markers if immune destruction of beta cells includes islets cell auto antibodies and auto antibodies against insulin. Autoimmune destruction of beta cells may be related to genetic as well as environmental factors. Certain environmental factors, such as viral infection, nutritional imbalances, low birth
weight and parental age may also be associated with TID [8]. Although subjects with TID are less often obese, the association of obesity with DM cannot be over-looked. Besides systemic signs, including polyuria, weight loss, fatigue and excessive thirst, oral symptoms incorporate xerostomia, periodontal inflammation and candidial infections [9].

Type I diabetes [10], sometimes called juvenile diabetes and begins most commonly in childhood or adolescence. In this form of diabetes, the body produces little or no insulin. It is characterized by a sudden onset this form is also called insulin-dependent diabetes because people who develop this type need to have daily injections of insulin.

Brittle diabetics are a subgroup of Type I where patients have frequent and rapid swings of blood sugar levels between hyperglycemia (a condition where there is too much glucose or sugar in the blood) and hypoglycemia (a condition where there is abnormally low levels of glucose or sugar in the blood). These patients may require several injections of different types of insulin during the day to keep the blood sugar level within a fairly normal range.

The more common form of diabetes, Type II [11], occurs in approximately 3–5% of Indians under 50 years of age, and increases to 10–15% in those over 50. More than 90% of the diabetics in the India are Type II diabetics. Sometimes called age-onset or adult-onset diabetes, this form of diabetes occurs most often in people who are overweight and who do not exercise.

Type II is considered a milder form of diabetes because of its slow onset (sometimes developing over the course of several years) and because it can usually be controlled with diet and oral medication. The consequences of uncontrolled and untreated Type II diabetes, however, are the just as serious as those for Type I. This form is also called noninsulin-dependent diabetes, a term that is somewhat misleading. Many people with Type II diabetes can control the condition
with diet and oral medications, however, insulin injections are sometimes necessary if treatment with diet and oral medication is not working.

Another form of diabetes called gestational diabetes can develop during pregnancy and generally resolves after the baby is delivered. This diabetic condition develops during the second or third trimester of pregnancy in about 2% of pregnancies. The condition is usually treated by diet, however, insulin injections may be required. These women who have diabetes during pregnancy are at higher risk for developing Type II diabetes within 5–10 years.

Diabetes can also develop as a result of pancreatic disease, alcoholism, malnutrition, or other severe illnesses that stress the body.

**Treatment of Type-I and Type-II diabetes**

A diet, oral hypoglycaemic agents and/or the administration of insulin usually manage to regulate the Blood Glucose concentration in type-II diabetics. The aim is not only to increase insulin concentrations, but also to reduce the levels of triglycerides and to normalize the level of protecting hdl-cholesterol in blood. First priority in the treatment of type- II diabetics is to reduce chronic hyperglycaemia and the associated long-term degenerative complications.

Type-I diabetic patients have an absolute insulin deficiency and can only be treated by insulin injections mostly in the subcutaneous tissues of arms, legs or abdomen (iddm). Main objective is to normalize the Blood Glucose concentration in order to reduce long-term complications. An intensive regime of short-acting insulin before meals with an additional injection of intermediate-acting insulin before bedtime mimic the normal insulin profile in blood and improve the metabolic control of the patient. Provided that the patient checks his Blood Glucose concentration regularly by means of Blood Glucose monitor device (finger-prick method) and adjusts the insulin dosage based on the results. Even better glucose regulation can sometimes be obtained by continuous subcutaneous insulin infusion (csii). Insulin delivery to the
peritoneal cavity (implantable pumps) can further improve metabolic control for a special group of type-1 patients, who are difficult to regulate [12], [13].

Insulin injections, in combination with frequent self-monitoring of Blood Glucose (smbg), have improved diabetic control. However, it is still difficult to achieve normoglycaemia because subcutaneous insulin injections do not mimic non-diabetic insulin secretion patterns sufficiently closely. High concentrations of peripheral insulin are needed to achieve sufficient insulin concentration levels in the portal vein where it can slow down the glucose production of the liver. Also the resorption of short-acting insulin from the subcutaneous tissue is much slower in comparison with insulin secretion from the beta cells. Moreover, with injections there is no feedback control of insulin delivery rates according the prevailing glucose level. Two other important approaches to improve metabolic control in type-1 diabetics are:

- The transplantation of the pancreas or isolated islets of Langerhans.
- The use of continuous glucose monitoring systems (i.e. glucose sensors) preferentially combined with a feedback controlled insulin dosage system.

4.2. Anatomy and Physiology of Pancreas

The pancreas is an endocrine and exocrine organ located retroperitoneally in the upper abdomen overlying the spine. The head and uncinate process lie within the curve of the duodenum, while the body and tail extend to the gastric border of the spleen. The pancreas is supplied by the gastroduodenal arteries and by branches of the splenic artery. The splenic vein and artery run superiorly and posteriorly; the mesenteric vein lies in the angle between the head and body of the gland. At this point the superior mesenteric vein and splenic vein join to form the portal vein. Fig 4.1.
Fig 4.1: Relationships and blood supply of pancreas.

The islets of Langerhans, clumps of cells scattered throughout the gland, produce the endocrine secretion of the pancreas. Their hormones, secreted directly into capillaries, include insulin, which is produced by the beta cells, and glucagon, pancreatic peptide, somatostatin and other hormones secreted by nonbeta cells.

The exocrine portion of the pancreas accounts for about 80% of the total glandular volume. It consists of at least two functional units: acinar cells, which secrete primarily digestive enzymes; and centroacinar or ductal cells, which secrete fluids and electrolytes Fig 4.2. Pancreatic secretion is regulated by several peptides that are released from the gastrointestinal tract. Some of these peptides, such as secretin and cholecystokinin (CCK), stimulate pancreatic secretions, whereas somatostatin and pancreatic polypeptide inhibit their release. The pancreas secretes about 20 digestive enzymes and cofactors. Some enzymes are activated in the duodenum by enterokinases and calcium Fig 4.3. These enzymes account for most of the intraluminal digestion of dietary proteins, triglycerides and carbohydrates. They are also important in the cleavage of certain vitamins (such as A and B₁₂) from carrier molecules, thereby allowing them
to be absorbed efficiently. Because pancreatic enzymes are secreted in great excess, maldigestion and serious nutritional deficiencies occur only when over 90% of the gland has been destroyed.

Fig 4.2: Schematic representation of acinar structure of exocrine pancreas

Fig 4.3: Role of cholecystokinin/pancreozymin and of enterokinase activation in pancreatic secretion.

4.3 The History of Insulin—Discovery of Insulin for Blood Glucose meter

In 1921 the Canadian scientists Fredrick G. Banting, Charles H. Best, J.J.R. Macleod and James B. Collip discovered insulin, a peptide (small protein hormone) which lowers blood sugar. They extracted insulin from the islets of animal pancreases. Up to that time type I diabetes was a virtual death sentence for patients suffering from it. Now, it could for the first time be treated successfully.
**First Diabetics on Insulin**

In January 1922, Bovine insulin was first given to humans by injection. It was still so impure that as a result of the first insulin injection Leonard Thompson had a 7.5 cm callus at the injection site on his left buttock. The co-discoverers, in particular James Collip, continued their work to purify the insulin extract to make it safer and more effective. Nevertheless, the quality of the insulin administered at that time was far from the quality of today's products. Each vial of insulin had a different effect because of differing purity. That is why Elizabeth Hughes, one of the first diabetics to be treated with insulin, often had hypoglycemic reactions. She also suffered pain and swelling at the injection site, especially when large quantities of insulin were injected.

**4.4 Blood Glucose sensors**

The concept of a glucose sensor was first introduced by Clark & Lyons in 1962. In their article dealing with continuous monitoring of blood chemistry, they suggested that a thin layer of soluble enzyme might be retained at the surface of an oxygen electrode using a dialysis membrane. Glucose and oxygen would diffuse into the enzyme layer from the sample site and the consequent depletion of oxygen would provide a measurement of the glucose concentration. The first article describing an immobilized enzyme electrode was due to Updike & Hicks in 1967. They immobilized the enzyme glucose oxidase in a polyacrylamide gel at an oxygen electrode. Since this pioneer work in the 1960s, reasonable research effort has been devoted to the development of glucose sensors by a number of research groups worldwide. Today, glucose sensor research is a relatively mature and well-worked research field. The majorities of sensors are based on electrochemical principles and employ enzymes as biological components for molecular recognition. Several new techniques for glucose sensing have been developed in clinical practice as well as in biotechnology and the food industry. This has inspired the development of in vivo glucose sensing techniques other than the existing enzyme based...
Improved diabetes control remains a motivation behind the research efforts being focused on development of an implantable glucose sensor. Still, the absence of a glucose sensor in clinical practice after all these years of research makes it clear that the in vivo implementation of these devices is very difficult. Despite good in vitro sensor performance it has been observed that subcutaneous implanted glucose sensors show a significant decay in sensitivity and poor selectivity over the implantation period. Several different explanations have been proposed, but in general there is no structural approach to assess the contribution of different failure mechanisms to the functional instability of implanted sensors.

**4.4.1. Electroenzymatic Approach**

Electroenzymatic sensors based on polarographic principles utilize the phenomenon of glucose oxidation with a glucose oxidase enzyme [25]. The chemical reaction of glucose with oxygen is catalyzed in the presence of glucose oxidase. This causes a decrease in the partial pressure of oxygen (PO$_2$), an increase in pH, and the production of hydrogen peroxide by the oxidation of glucose to gluconic acid according to the following reaction.

$$ \text{Glucose} + \text{O}_2 \rightarrow \text{Gluconic acid} + \text{H}_2\text{O}_2 $$

**4.4.2. Optical Approach**

A number of innovative glucose sensors, based on different optical techniques, have been developed in recent years. A new fluorescence-based affinity sensor has been designed for monitoring various metabolites, especially glucose in the blood plasma [26]. The method is similar in principle to that used in radioimmunoassay. It is based on the immobilized competitive binding of a particular metabolite and fluorescein labeled indicator with receptor sites specific for the measured metabolite and the labeled ligand (the molecule that binds).
4.4.3. Attenuated total reflection and Infrared Absorption Spectroscopy

The application of multiple infrared ATR spectroscopy to biological media is another potentially attractive noninvasive technique. By this means, the infrared spectra of blood can be recorded from tissue independently of the sample thickness, whether other optical transmission techniques are strongly dependent on the optical transmission properties of the medium. Furthermore, employing a laser light source makes possible considerable improvement of the measuring sensitivity. This is of particular interest when one is measuring the transmission of light in aqueous solutions, because it counteracts the intrinsic attenuation of water, which is high in most wavelength ranges.

4.5. Design of Micro Controller based Blood Glucose meter

The method for measuring the glucose concentration in a whole blood sample will be of the amperometric type. The glucose sensor is an electrochemical diagnostic strip which uses glucose oxidase enzymes in conjunction with three electrically conductive electrodes. Two of these electrodes are ‘working’ electrodes meaning they are the measured electrodes, and the third is a reference electrode. These electrodes have impedance which makes them suitable for amperometric measurement. With a strip inserted into the meter, a predetermined current (1 μA) is constantly applied between the working and reference electrodes. The potential difference of this current is constantly monitored by the meter while the strip is in place.

The enzymes of the strip are contained within a ‘reaction zone’. When the enzyme becomes catalytically active (blood sample is applied correctly), the enzyme and mediator compound transfer electrons to the electrode. This then bridges the gap between the electrodes and results in a rapid voltage drop. When this drop goes below a predetermined threshold, sample detection is initiated. A constant voltage (300 mV) is then applied to the strip, and the electrical response is measured for a predetermined amount of time. If there is a 10% difference
in electrical response between the two working electrodes, then the meter deems an error. This requires either more blood or inserting a new strip and repeating the test. The determination of this requirement is related to the amount of time that has passed in error.

The current that is produced with correct fluid application is proportional to the glucose concentration of the sample. Determination of the glucose concentration comes from comparison to previously obtained control values. The current-to-glucose relationship becomes linear after about 3 seconds from the initiation time. The measurement is taken at around 5 seconds after, to account for any delay. The measurement could be taken at a later time, but keeping the measurement process relatively fast is beneficial to the user. Of course, once a predetermined time is set (5s), accurate and precise results require that the same time be used each time. In any case, the accuracy of the current determination depends on the accuracy of the initiation determination. Fig 4.4 shows the schematic diagram of test strip.

![Test Strip Schematic](image)

**Fig 4.4 : Test Strip Schematic**

The proposed meter will use commercial test strips designed for the One Touch Ultra glucose meter made by Lifescan. The testing procedure begins when a single glucose test strip is then inserted into the port at the top of the meter. The meter will then tell the user to apply the blood sample to the strip. The measurement will take approximately 10 seconds and the results will then be displayed on the screen.

A large, high contrast, liquid crystal display (LCD) will be used for easy viewing of the instructions and results for the patients. It will have step-by-step display output for the patients.
The glucose meter will be controlled through the use of a Micro Controller. This Micro Controller will essentially interface and communicate with each part of the proposed meter. Its main function is to communicate with the user interface and allow the patient to control what function the meter is performing. This will be done visually through the LCD screen.

The Micro Controller will receive incoming data from the glucose test circuit, the site of the chemical testing of the patients' blood. This will happen when the user inserts a test strip and adds a blood sample of the appropriate size. The LCD screen will display instructions and test results as from the Micro Controller at the proper times.

4.6. Hardware design of a Blood Glucose meter

The Micro Controller we have chosen for this design is the PIC18f4520, manufactured by Microchip. This particular Micro Controller incorporates all of the functions necessary to meet our specifications. The Micro Controller will be used to control the glucose test circuit, analyze measurements, handle user input from buttons, drive an LCD display, and control a speech module. This chip will be easy to program due to the equipment and development software available in the lab. The Micro Controller will be programmed in assembly using Microchip MPLab IDE.

As previously stated, the Micro Controller will be programmed using MPLab IDE and Hi-Tech C. Programming modules will be needed for serial communication to the LCD display drivers. The code will be written in C and translated into assembly language and transferred to the Micro Controller. The LCD display drivers will also be programmed on the Micro Controller.

The LCD display will be controlled by the Micro Controller using the Parallel Data Port. The LCD will show the instructions for proper operation of the meter and display results after test completion. The Serial RS-232 communication is being phased out of most home computers. The block diagram of the Blood Glucose meter is as shown in fig 4.5
Fig 4.5: Block Diagram of Blood Glucose Meter
The implementation of Blood Glucose measurement is by cascading several stages as shown in the Fig 4.5 which depicts the system block diagram and fig 4.6 describes the circuit diagram of Blood Glucose meter. The design consists of hardware and software sections. The device hardware constructed in the present study consists of the following functional units. They are
1. Sensor unit - Glucose Test stripe

2. Signal conditioning unit
   2.1. Glucose detection and filter circuit
   2.2. Glucose Trigger circuit

3. Micro controller - PIC18F4520

4. RS-232 Driver/Receiver (RS232)

5. Data presentation unit

6. Power supply

4.6.1. Sensor unit - Glucose Test Stripe

The sensor unit consists of a Glucose Test Stripe to which a drop of the blood sample applied that transmits the sensing signals to next stage, signal-conditioning unit. The Glucose Measurement System measures the amount of glucose in whole blood. In present design we are using One touch Ultra Test strip for measurement of Blood Glucose as shown in fig 4.7. A whole blood sample is applied to the top edge of the OneTouch Ultra Test Strip, automatically drawn into the reaction cell of the test strip.

The glucose test strip is connected to the circuit at the component labeled S1. A potential of 400 mV is applied between the first and third pins. The voltage difference is required to initiate the redox reaction on the test strip. The current produced from the test strip comes from pin 3 of S1 and connects to the inverting input of the LM358. Another potential is applied across pins 4 and 5 of S1 to detect when a test strip is inserted. The test strip has an electrode across the bottom which connects the two pins when inserted properly into the meter. The test strip circuit is shown in Fig 4.8.
4.6.2. Signal conditioning unit

In general any Instrumentation system consist of various units staring from sensors to data representation units, among that signal conditioning is a vital process. This system consists of Amplifiers, Filters, and ADC etc and the bio-medical instruments consist of signal conditioning units to process very low frequencies. Where noise interference is a major problem. Fig 4.9 shows the circuit diagram of signal conditioning unit consists of

1. Glucose detection and filter circuit

2. Glucose trigger circuit
4.6.2.1. Glucose Detection and Filter Circuit

When we insert a test stripe in the device 4 and 5 pins of the test stripe will contact each other and PIC micro controller will sense the presence of the strip. The current output from the glucose test strip is connected to pin 2 of inverting input of the LM358. The current is converted to a voltage in LM358 and output at pin 1 is given to the filter circuit IC TL072. The glucose detection circuit is as shown in fig 4.10.
Glucose filter circuit

The filter uses a TL072 dual op amp and is configured as a 100 Hz Sallen-Key Low Pass Butterworth filter. Fig 4.11 shows the filter circuit.

Glucose detection circuit

The glucose measurement originates as a small current generated by the chemical reaction occurring in the test strip. The test strip contains glucose oxidase, a chemical that binds to D-glucose to start a redox reaction. The redox reaction breaks down the glucose and releases
electrons. The flow of electrons is known as current and is collected by electrodes built-in to the test strip. The current is converted to voltage through the use of a current-to-voltage converter.

A current-to-voltage converter is simply an op amp with a feedback resistor. The op amp is used as a high impedance source that forces all of the current to flow through the resistor. Fig 4.12 shows the theoretical schematic for a current-to-voltage converter.

![Fig 4.12: Current-to-Voltage Converter Schematic.](image)

Ohm's Law is used to calculate the value of the resistor. Experimental data shows that an average current produced by the glucose test strip is 20μA.

\[ V = I \times R \]

Because an average value is being used, \( V \) is chosen to be 2 volts so that it is about half the maximum voltage that can be used by the analog-to-digital converter.

\[ 2 = 20 \times 10^{-6} \times R \]

\[ R = 100000 \text{ Ohms} \]

**LM358 – Dual Low Power Operational Amplifier**

The LM358 dual operational amplifiers features are 1) low power drain, 2) a common mode input voltage range extending to ground/VEE, and 3) single supply or split supply operation. LM358 amplifier has several distinct advantages over standard operational amplifier types in single supply applications. They can operate at supply voltages as low as 3.0 V or as
high as 32 V. The common mode input range includes the negative supply, thereby eliminating
the necessity for external biasing components in many applications. The output voltage range
also includes the negative power supply voltage.

**TL072 Low Noise JFET Input Operational Amplifier**

The JFET-input operational amplifier TL072 has low input bias and offset currents and
fast slew rate. The low harmonic distortion and low noise make the TL072 ideally suited for
high-fidelity and audio preamplifier applications. Each amplifier features JFET inputs (for high
input impedance) coupled with bipolar output stages integrated on a single monolithic chip.

**Features**

- Low Power Consumption
- Wide Common-Mode and Differential Voltage Ranges
- Low Input Bias and Offset Currents
- Output Short-Circuit Protection
- Low Total Harmonic Distortion ... 0.003% Typ
- Low Noise Vn = 18 nV/Hz Typ at f = 1 kHz
- High Input Impedance ... JFET Input Stage
- Internal Frequency Compensation
- Latch-Up-Free Operation
- High Slew Rate ... 13 V/μs Typ
- Common-Mode Input Voltage Range Includes VCC+

**Glucose Voltage Measurement:**

The glucose measurement is taken from a single acquisition from the analog-to-digital
converter. When a sample is applied to the test strip the voltage jumps to a peak value and then
begins to decay linearly between 1 and 5 seconds. The voltage reading is taken 2 seconds after
the sample is applied. Fig 4.13 shows a typical voltage curve for glucose.
The voltage level is then converted to a glucose concentration. This equation was determined experimentally. To determine the glucose-voltage characteristic, measurements were taken at 2 seconds over a range of glucose concentrations (20-400 mg/dL). The glucose concentration was plotted as a function of voltage and is shown in Fig 4.14. A linear trend line was applied to the curve to determine the slope and intercept of the line. This trend line is the glucose-voltage equation shown in Equation

\[
\text{Concentration} = (\text{voltage}) \times 922.23 - 22.9
\]

4.6.2.2. Glucose Trigger circuit

The glucose trigger is used to start the analog-to-digital conversion. The trigger circuit is made using a LM358 op amp as a comparator and the outputs of the comparator are input to an XOR gate, as shown in Fig 4.15.
Comparator 1 is set up with a reference voltage of 0.05 V. Comparator 2 is set up with a reference voltage of 0.10 V. These voltages were picked because they are very near the start of the glucose signal. When the glucose voltage level reaches 0.05 V the output of Comparator 1 goes HIGH. Once the glucose voltage level goes above 0.10 V the output of Comparator 2 goes HIGH. The outputs of the comparators are input into the XOR gate. When one of the comparators is HIGH, the output of the XOR gate is HIGH. If both of the outputs of the comparators are either HIGH or LOW the output of the XOR gate is LOW. Table 4.2 shows a truth table for the glucose trigger circuit.

**Table 4.2 : Glucose Trigger Truth Table**

<table>
<thead>
<tr>
<th>Input Voltage</th>
<th>Comparator 1 Out</th>
<th>Comparator 2 Out</th>
<th>XOR Out</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>LOW</td>
<td>LOW</td>
<td>LOW</td>
</tr>
<tr>
<td>0.05</td>
<td>HIGH</td>
<td>LOW</td>
<td>HIGH</td>
</tr>
<tr>
<td>0.07</td>
<td>HIGH</td>
<td>LOW</td>
<td>HIGH</td>
</tr>
<tr>
<td>0.10</td>
<td>HIGH</td>
<td>HIGH</td>
<td>LOW</td>
</tr>
<tr>
<td>0.15</td>
<td>LOW</td>
<td>LOW</td>
<td>LOW</td>
</tr>
</tbody>
</table>

The microcontroller detects the falling edge of the trigger pulse. This signal is then used in the programming of the microcontroller to start the delay and acquisition sequence in the code. Two seconds after the trigger pulse occurs, the analog-to-digital converter takes a single measurement.
The connection diagram for the glucose trigger circuit is shown in Fig 4.16. The only difference between the theoretical schematic in Fig 4.16 and the actual circuit is the 1k pull-up resistors on the inputs and outputs of the 7486 XOR gate. The pull-up resistors ensure that the input and output voltages do not drop below 5 volts. Without the pull-up resistors the input and output voltages were only reaching approximately 4 volts and could be lower than the digital threshold required for a HIGH input on the microcontroller.

4.6.3. Micro controller PIC 18F4520

The microcontroller is connected to each component of the meter. The processor is responsible for the analog-to-digital conversion, LCD control, user interface, and communication with a serial device. The microcontroller uses a 5 MHz clock. Fig 4.17 is interfacing connections to the microcontroller.
PIC 18F4520

PIC18F4520 is an Enhanced Flash Microcontroller with 10-Bit A/D and nanoWatt Technology Power Managed Modes. The PIC18F4520 microcontrollers have high computational performance at an economical price – with the addition of high endurance, Enhanced Flash program memory. The PIC18F4520 introduces design enhancements that make these microcontrollers a logical choice for much high performance, power sensitive applications.

Features:

- High-current sink/source 25 mA/25 mA
- Three programmable external interrupts
- Four input change interrupts
- Enhanced Capture/Compare/PWM (ECCP) module
  - One, two or four PWM outputs
  - Selectable polarity
  - Programmable dead time
  - Auto-Shutdown and Auto-Restart
- Master Synchronous Serial Port (MSSP) module supporting 3-wire SPI and I2C Master and Slave Modes
- Enhanced Addressable USART module:
  - Supports RS-485, RS-232 and LIN 1.2
  - RS-232 operation using internal oscillator block (no external crystal required)
  - Auto-Wake-up on Start bit
  - Auto-Baud Detect
- 10-bit, up to 13-channel Analog-to-Digital Converter module (A/D):
  - Auto-acquisition capability
  - Conversion available during Sleep
• Dual analog comparators with input multiplexing)

**Analog-to-digital converters:**

The connections to the glucose circuit are made through Pin 2 and Pin 4. The input to the analog-to-digital converter is Pin 2 and the input from the glucose trigger is Pin 4. The microcontroller is capable of 10-bit analog-to-digital conversion.

The analog-to-digital converter is configured with two control registers, ADCON0 and ADCON1. ADCON0 is used to configure the conversion clock, the input channel, and to power on the module. The analog-to-digital converter is set up to use an Fosc/8 conversion clock, read channel 0, and turn the module on. The Fosc/8 conversion clock is selected according to the maximum device frequency. The maximum device frequency is 5 MHz. Table 4.3 shows the A/D acquisition time vs. the maximum device frequency.

<table>
<thead>
<tr>
<th>AD Clock Source (Tad)</th>
<th>AD#0</th>
<th>Operation</th>
<th>ADCS2:ADCS1:ADCS0</th>
<th>Maximum Device Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 Tosc</td>
<td>000</td>
<td>1 Tosc</td>
<td>100</td>
<td>1.25 MHz</td>
</tr>
<tr>
<td>3 Tosc</td>
<td>001</td>
<td>3 Tosc</td>
<td>010</td>
<td>2.5 MHz</td>
</tr>
<tr>
<td>4 Tosc</td>
<td>010</td>
<td>6 Tosc</td>
<td>011</td>
<td>5 MHz</td>
</tr>
<tr>
<td>8 Tosc</td>
<td>011</td>
<td>2 Tosc</td>
<td>101</td>
<td>10 MHz</td>
</tr>
<tr>
<td>16 Tosc</td>
<td>101</td>
<td>32 Tosc</td>
<td>010</td>
<td>20 MHz</td>
</tr>
<tr>
<td>32 Tosc</td>
<td>110</td>
<td>64 Tosc</td>
<td>110</td>
<td>20 MHz</td>
</tr>
<tr>
<td>64 Tosc</td>
<td>x11</td>
<td>2^{2^N}</td>
<td>x11</td>
<td>(Note 1)</td>
</tr>
</tbody>
</table>

**4.6.4. RS232-Driver/Receiver**

RS-232 (Recommended Standard 232) is a standard for serial binary data signals connecting between a DTE (Data Terminal Equipment) and a DCE (Data Circuit-terminating Equipment). It is commonly used in computer serial ports. The standard sets out to ensure compatibility between the host and peripheral systems by specifying Common voltage & signal levels, Common pin wiring configurations and control information between the host and peripheral Systems.

Details of character format and transmission bit rate are controlled by the serial port hardware, often a single integrated circuit called a USART that converts data from parallel to
asynchronous start-stop serial form. Voltage levels, slew rate, and short-circuit behavior are typically controlled by a line-driver that converts from the USART's logic levels to RS-232 compatible signal levels, and a receiver that converts from RS-232 compatible signal levels to the UART's logic levels. The explanation for RS-232 is given in chapter 3 of Blood Pressure measurement using the micro controller MCF51QE128. The circuit diagram interface MAX232 with PIC18F4520 is as shown in fig18. The MAX-232, it includes a Charge Pump, which generates +10V and -10V from a single 5v supply. This MAX-232 includes two receivers and two transmitters in the same package.

Fig 4.18 : RS232 interface with PIC18F4520 of Glucose meter

In the present design, the TX – Pin 25 of the micro controller is connected to the Pin 10 - T2in of the MAX232, and the RX - pin 26 of the microcontroller is connected to the Pin 9 – R2out of the MAX232. The interface between the max232 and RS-232 serial port is as shown in fig 4.18. i.e from pin 7 of MAX232 to 2 pin of the DB-9 serial pin connector, and pin 8 of the max232 is connected to the pin 3 of RS -232 connector.
By connecting the configurations as shown in fig 4.18, establish communication between the microcontrollers and transmit the glucose measured data. By establishing the communication between the two devices, i.e., we can transmit and receive data between PIC18F4520 to Personal Computer.

In the present study, we are transmitting the measured data of Blood Glucose to the Personal Computer. The transmitted data is utilized in further analysis with Integrated Electronic Health Record System to provide for the e-record in place of paper record of present system.

4.6.5. Output display unit

The measured Blood Glucose data are displayed on the Liquid Crystal display. In present work, we are using LM16200 (16 x 2 character) LCD display. The LCD connects to the microcontroller using 14 pins. There are eight parallel pins used for data transfer, one pin for the enable (E), one for the instruction/register select (RS), and one for the read/write control (R/W).

Fig 4.19 shows interfacing diagram of LCD display with PIC18F4520 micro controller.

---

Fig 4.19 : LCD interface circuit with PIC 18F4520
The text and instruction data are sent across pins 7-14 on the LCD screen. The instruction / register select commands are sent across pin 4. Pin 5 is used to receive the read / write commands from the microprocessor. Pin 6 is the enable clock and is used to latch in the data on pins 7-14. Pin 3 is used to set the contrast on the LCD. Pin 2 and Pin 1 are 5 volts and ground respectively. The instruction / register select command is used to tell the LCD if data or a control instruction is being written.

Text is written to the LCD screen by setting the R/S bit to 1 and writing the ASCII text to the eight-pin data bus. The LCD screen will read in the data on the data bus when the enable clock is set high and then low. The text information is read on the falling edge of the data clock.

When the LCD is initialized properly the screen should be blank. If the first row of characters is filled with dark boxes turn the power off and back on. The instructions for the meter should be displayed correctly after doing this.

4.6.6. Power supply

In present design the Blood Glucose meter operates on 5V power supply. The circuit diagram of the power supply is as shown in fig 4.20.

![Fig 4.20 : 5 v Power supply circuit](image-url)
4.7 Software Development of Blood Glucose Meter

The processing unit utilizes the logic implemented in the software for accurate detection of Blood Glucose. The software checks the input signal from the Glucose test strip by blood sample of the patient and measures the Blood Glucose of the signal. The algorithm and flow chart for the Blood Glucose measurement shown below

4.7.1 Algorithm

1. Initialize Watchdog timer and ports
2. Initialize Ports, LCD, Operational Amplifiers
3. Initialize ADC and set its sampling rate using timer
4. Initialize USART
5. Enable interrupts
6. Detect the glucose test stripe
7. Determine the current produced from the stripe.
8. Convert current to voltage for determination of glucose concentration.
9. Convert analog signal to digital signal to using inbuilt ADC.
10. Calculate the Blood Glucose concentration
11. Display the values on LCD
12. Transmit signals to Personal Computer
4.7.2. Flowchart

**Main**

Start

- Initialize watchdog timer and ports.

- Initialize LCD and enable interrupts

- Initialize operational Amplifiers

- Set ADC and set sampling rate, Enable USART

- If glucose stripe is present
  - Yes: Find glucose concentration
  - No: Convert current to voltage and convert to digital using ADC

- Filter the signal & calculate Blood Glucose

- Display Blood Glucose values

- Transmit results to PC for EHR

- End

**Isr ADC**

- ADC()

- Read ADC register

- Return

- Filter()

- Filter signals

- Return

- Set_LCD()

- Set common and segment lines

- Return

Fig 4.21: Flow chart for Blood Glucose Meter
In the present study the C language used for the development of software having the following features. The ‘C’ programming language is growing in importance and has become the standard high-level language for real-time embedded applications. To development of C programs for PIC18F4520 executing on a PC is now familiar with MPLAB IDE only. This largely due to the inherent language flexibility, the extent of support and its potential for portability across a wide range of hardware [31]. Specific reasons for its use include

- It is a midlevel with high level features (such as support for functions and modules) and low-level features (such as good access to hardware via pointers)
- It is very efficient, it is popular and well understood

4.7.3. MPLAB-IDE

MPLAB IDE is a Windows OS based Integrated Development Environment (IDE) for the Microchip Technology Incorporated PIC microcontroller (MCU) families. MPLAB IDE allows writing, debugging, and optimizing PIC MCU applications for firmware product designs. It provides tools to allow you to

- Create source code using the built-in editor, Assemble, compile and link source code using various language tools.
- Debug the executable logic by watching program flow with the built-in simulator, or in real time with the MPLAB emulator/Debuggers, Make timing measurements with the simulator, View variables in Watch windows.
- Program firmware into Emulators and Debuggers.

(a) Setting up the Development Mode

To select the device, select Configure>Select Device. A dialogue box shown below fig 4.22(a) will be displayed. Choose the PIC18F4520 from the pull-down list of available controllers supported and click OK.
(b) Create a New Project

Select **Project>New** from the menu and we will see a dialog box shown in fig 4.22(b).

Enter a name for new project, for example lab1. Click OK when everything is entered.

**Set Language Tool Location**

Select **Project>Set Language** Tool Locations to confirm the location of the Microchip C18 Toolsuite and select the "MPLAB C18 C Compiler (mcc18.exe)". The Location of Selected Tool text box is shown fig 4.22(c).

**Selecting the Toolsuite**

Select Project>Select Language Toolsuite. For “Active Toolsuite”, select “Microchip C18 Toolsuite”, and it will appear under “Toolsuite Contents” as shown in fig 4.22(d).

**Creating a Simple New Source File**

- Use the **File>New** menu option, a blank edit window as shown in fig 4.22(e) will open in the workspace.
- Use the **File>Save As** menu option and save the empty file as lab1.c. Then click the **Save** button shown in fig 4.22(f)

**Entering Source Code**

```c
#include <p18f4520.h>
define size 10
void main ( )
{
    unsigned char x, y[size];
    for (x = 0; x < size; x++)
        y[x] = x + 2;
    TRISB =0;
    PORTB = 0x0F;
}
```

- Save the file by using the **File>Save** menu item.
(c) Building the Project

Add the source file (.c) and linker script (.lkr) to the project. Now we have to build the project.

- Select **Project>Add Files to project** and select the file and click **Open** button which appears shown in fig 4.22(g). The newly inserted file should appear in the project pane under “Source Files” as shown in fig 4.22(h).

- Next, insert the linker script using the same method as shown above, but instead of selecting the source file you select the linker script at C:\mee18\lkr directory with the name of 18f4520.lkr.

The newly inserted linker script file should appear in the project pane under “Linker Scripts” as shown in fig 4.22(h). Save the project by selecting **Project>Save project**.

- After adding the two files to the project, the next thing to do is to set the library path. Select **Project>Build Options>project**, a build option dialog box as shown in fig 4.22(i). Enter the library path, C:\mee18\lib, and Click **OK** when you are done.

- Select **Project>Build All** to build the project. Your file should build successfully.

The Build Output window will display “Build Succeeded” as shown in fig 4.22(j). Now we complete project

(d) Execution of Program

- Select the **Debugger>Run** or press **F9** to run the application. We will see “Running...” appear on the status bar.

- Now we can see the values of variables at any time by putting the mouse cursor over their names anywhere in the source file. A small output window will pop up showing the current value as shown in fig 4.22(k).
Fig 4.22 : MPLAB Integrated Development Environment

After creation of project and the program, we executed the program in simulator. Then executed program is downloaded in to the micro controller using JTAG. The download
program is executed in micro controller with external hardware interface then we can get the results. If we wrong results then modify the program and do the same process as above till to get the correct results. Software program for Blood Glucose measurement is present in Annexure-II

4.8. Measurement and operation of Blood Glucose

While the meter is off, insert a test strip into the slot on the top of the meter. Be sure that the test strip is inserted with the contact bars facing up and going in first. Push the test strip all the way in until it can go no further. With the test strip inserted, turn the meter on by pressing the switch on the meter.

Obtain Sample

Obtain a round drop of blood using the OneTouch Ultrasoft Adjustable Blood Sampler. The **blood sample must be at least 1.0 μL in volume** to fill the confirmation window.

Apply Sample

When a large enough drop of blood has formed on your fingertip or forearm, touch and hold the drop of blood to the narrow channel in the top edge of the test strip.

- Do not apply sample to front or back of the test strip.
- Do not push your finger against the test strip.
- Do not apply a smeared sample.

Hold the blood drop to the top edge of the test strip until the confirmation window is full. Upon a successful application of blood, the meter will count 2 seconds and compute the glucose level. If the confirmation window does not fill completely before the meter begins to count down, do not add more blood to the strip. Discard the strip and repeat the test again.

The taking blood sample and blood sample applies to test strip and sample fills is as shown in fig 4.23, 4.24, 4.25 respectively.
The PIC 18f4520 to measure glucose concentrations must perform several functions. First, a current is applied between the working and reference electrodes. The circuit will monitor the potential difference across the electrodes to determine the presence of the blood sample. When the potential drops below a predetermined threshold, the circuit switches to a constant voltage across the electrodes. The resulting current from the test strip is monitored through the operational amplifier LM358. The output of the amplifier is filtered and amplified then the analog signals are input to the Micro Controller’s analog-to-digital converter. The analog to digital converter will convert the analog signal to digital and The Blood Glucose level of a patient is displayed on an LCD. The Blood Glucose level will appear on the screen about 2 seconds after a successful blood application. The real time samples are also sent via an RS232 to a PC. Once the test is complete, the test strip can be removed from the meter, and the meter can be turned off.

To repeat the test, be sure that the previous test strip has been removed, and the meter has been turned off. Then repeat the procedure as instructed above. Further the real time measured values are transmitted to PC through RS232 for IEHRS.
4.9. Calibration and Analysis

The present work on Blood Glucose measurement is based on invasive method as a part of Integrated Electronic Health Record System. The measurement of glucose level in the blood sample is obtained by amperometric method and the measurement of invasive method encounters problems from quantity of the sample, time of measurement and specified location of sample on the glucose test strip etc. Hence the calibration process is more complex involving number of volunteers for the measurements of Blood Glucose. As large number of data being collected before arriving conclusion on the response of the glucose measurement. The measurements we carried out on all age groups. The actual measurements carried out with designed instrument as well as with an international standard Ultra 2 Blood Glucose meter.

The measurements were carried out on the system is good agreement with standard meter values. The empirical calibration process, the measurements exhibited slight deviation, but all these measurements are within the tolerance range. The response time of the instrument was also well as compared with Ultra 2 Blood Glucose meter. In general the glucose meters are calibrated with the control solution instead of blood sample. If it falls with in range then group of test strips are used for the measurement.

4.10 Results & discussions.

As a part of an Integrated Electronic Health Record System (IEHRS) an attempt has been made by the author to develop a Blood Glucose meter with the advanced Micro Controller PIC18F4520 which is handheld, rugged, and low cost compared to other standard meters operated with minimum power consumption.
The ultimate purpose of Diabetes assessment is to obtain valid information on sugar level to guide clinical or public health decision. Diabetes has no cure, but may be controlled with the monitoring. Blood glucose levels vary during a regular day. The acceptable range of glucose concentration is 70 - 110 mg/dL. Glucose levels spike shortly after eating and may reach as high as 180 mg/dL but should normalize within two to three hours. Glucose measurements have been traditionally performed by trained health professionals in medical settings.

Various methods are available for measuring sugar levels to control diabetes should be helpful. The glucose meter measures sugar level by taking samples of blood, typically taken from the fingertip. Recognition of the increasing use of digital readout instruments required a glucose sensor, which is an electrochemical diagnostic strip that uses glucose oxidase enzymes in conjunction with three electrically conductive electrodes. At present, self-measurement devices are used largely instead of clinical procedural methods which require a large sample of blood, time consuming and cost.

In the present study, the developed Blood Glucose meter is tested and compared with the International standard meter of Ultra 2 blood glucose meter for different age groups of patients between 17-80 years with diabetic and the non-diabetic and results are tabulated in Table 4.4. It shows good agreement with the standard meter.
Table 4.4: Measured Blood Glucose values

<table>
<thead>
<tr>
<th>S. No</th>
<th>Ultra 2 mg/dl</th>
<th>Clinical Chemistry Analyzer RT1904C mg/dl</th>
<th>Present meter mg/dl</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>93</td>
<td>93</td>
<td>90</td>
</tr>
<tr>
<td>2</td>
<td>136</td>
<td>134</td>
<td>131</td>
</tr>
<tr>
<td>3</td>
<td>149</td>
<td>148</td>
<td>152</td>
</tr>
<tr>
<td>4</td>
<td>183</td>
<td>182</td>
<td>180</td>
</tr>
<tr>
<td>5</td>
<td>213</td>
<td>211</td>
<td>215</td>
</tr>
<tr>
<td>6</td>
<td>315</td>
<td>317</td>
<td>321</td>
</tr>
<tr>
<td>7</td>
<td>337</td>
<td>332</td>
<td>339</td>
</tr>
<tr>
<td>8</td>
<td>357</td>
<td>352</td>
<td>349</td>
</tr>
</tbody>
</table>

The meter also provided with RS-232 interface to upload the measured data on to a Personal Computer for further analysis with IEHR System.

The following precautions has to be followed while taking the self Blood Glucose measurement by the user are

1. Insert the test strip with contact bars end first and facing up into the test port fully. The bars must be all the way into the meter to avoid an inaccurate result.

2. The blood sample must be at least 1.5 to 2 micro liters in volume and the blood should be completely filled the confirmation window before the measurement.

3. Wash the hands before taking blood sample.
4. Taking the blood sample at a correct position, with special attention to the position of the pick-up

5. Recording the values carefully and systematically

The instrument is easily portable and can be carried to the site where the sample study is to be conducted. At present a vast research and development is going on all over the world to develop Non-invasive method for the measurement of diabetes mellitus which gives a great relief to the patients without pain. The author is also very interested to design and develop a non-invasive technique glucose meter that definitely serves and provides a great relief to the diabetic mellitus patients is controlling the diabetes effectively. The meter is further is interfaced with Personal Computer through RS-232 to download the Glucose measurements for the further analysis with the IEHR System.
#include <pic.h>
#include <conio.h>
#include <stdio.h>
#include "always.h"
#include "delay.h"

void serial_setup(void)
{
    data sheet under 'USART async. modes'

    BRGH=1, Fosc=3.6864MHz  BRGH=1, Fosc=4MHz
    BRGH=1, Fosc=8MHz       BRGH=1, Fosc=16MHz

    Baud  SPBRG  Baud  SPBRG  Baud  SPBRG  Baud  SPBRG
    1200  191   1200  207.3  1200  415.7  9600  103
    2400  95    2400  103.2  2400  207.3  19200 51
    4800  47    4800  51.1   4800  103.2  38400 25
    9600  23    9600  25.0   9600  51.1   57600 16
    19200 11   19200 12.0   19200 25.0  115200 8

    //define BAUD
    #define DIVIDER ((PIC_CLK/(16UL * BAUD) -1))
    //define HIGH_SPEED
    SPBRG=DIVIDER;

    BRGH=HIGH_SPEED;  //data rate for sending
    SYNC=0;           //asynchronous
    SPEN=1;           //enable serial port pins
    CREN=1;           //enable reception
    SREN=0;           //no effect
    TXIE=0;           //disable tx interrupts
    RCIE=0;           //disable rx interrupts
    TX9=0;            //8-bit transmission
    RX9=0;            //8-bit reception
    TXEN=0;           //reset transmitter
    TXEN=1;           //enable transmitter
}

unsigned char dummy;

#define clear usart_errors_inline
if (OERR) {
    TXEN=0;
    TXEN=1;
    CREN=0;
    CREN=1;
}
if (FERR) {
    dummy = RCREG;
    TXEN=0;
    TXEN=1;
}
void putch(unsigned char c) {
    while (!TXIF) {
        clear_uart_errors_inline;
        CLRWDT();
    }
    TXREG=c;
    DelayUs(60);
}

void putchhex(unsigned char c) {
    unsigned char temp;
    temp=c;
    c=(c >> 4);
    if (c<10)
        c+=48;
    else
        c+=55;
    putch(c);
    c=temp;
    c=(c & 0x0F);
    if (c<10)
        c+=48;
    else
        c+=55;
    putch(c);
}

void putinthex(unsigned int c) {
    #define ramuint(x) (*((unsigned int *) (x)))
    #define ramuint_hibyte(x) (*((unsigned char *)&x)+1))
    #define ramuint_lobyte(x) (*((unsigned char *) (x)))
    putchhex(ramuint_hibyte(c));
putchhex(ramuint_lobyte(c));
#undef ramuint(x)

#undef ramuint_hibyte(x)
#undef ramuint_lobyte(x)
#undef ramuchar(x)
}

#include "lcd_lib.h" ; LCD routine headers.
#include "del_lib.h" ; Delay routine headers.

RESETVECTOR EQU 0x000 ; Address of RESET vector.
PERIPHVECTOR EQU 0x004 ; Address of peripheral interrupt vector.
CODESTART EQU 0x008 ; Starting location of program code.

UDATA ;
COUNT RES 1 ;
LCD.

ifndef A_Dev ce
__CONFIG CP OFF & _WDT OFF & BODEN ON & _PWRTE ON & _XT OSC &
_WRT ENABLE ON & _LVP OFF & _CPD OFF

endif
ifdef A_Dev ce
messg "A revision device."

__CONFIG CP OFF & _WDT OFF & BODEN ON & _PWRTE ON & _XT OSC &
_WRT OFF & _LVP OFF & _CPD OFF

endif

;; Main Program.

... PORTB
banksel TRISB
movlw OxFO
movwf TRISB
call LCDJnit
movlw OxOC
call LCDCtrlWrite
;; Display line 1 text.
;; Establish a pointer to the NULL-terminated string.

banksel LCD_PTRLOW
movlw low Sline1
movwf LCD_PTRLOW
movlw high Sline1
movwf LCD_PTRHIGH
call LCD_TxStringK
;; Move down to start of second line.
movlw 0xC0
call LCD_CtrlWrite
;; Send out the string to the second line.
banksel LCD_PTRLOW
movlw low Sline2
movwf LCD_PTRLOW
movlw high Sline2
movwf LCD_PTRHIGH
call LCD_TxStringK

;; Change to CGRAM mode.

movlw 0x40
call LCD_CtrlWrite
;; Send 8 characters of data.
banksel LCD_PTRLOW
movlw low CustomChar0
movwf LCD_PTRLOW
movlw high CustomChar0
movwf LCD_PTRHIGH
movlw 64
; 8 chars * 8 bytes/char = 64
call LCD_TxStringKN
movlw 0xC0
call LCD_CtrlWrite
DisplayPause:
movlw 0xCE
call LCD_CtrlWrite
movlw 0x06
call LCD_Data_Write
movlw 50
call DELAY_Wx10ms
DisplayPause2:
movlw 0xCE
call LCD_Ctrl_Write
movlw 0x00
call LCD_Data_Write
movlw 50
call DELAY_Wx10ms
goto DisplayUp
References


*****