CHAPTER 2
DIAMOND IMAGE ACQUISITION USING SCANNERS

2.1 Introduction

The first step in Digital Image Processing is Image Acquisition that is, to acquire a digital image. A digital image is an image \( f(x,y) \) that has been discretized both in spatial co-ordinates and brightness [53]. Digital image processing encompasses a broad range of hardware and software. The most basic requirement for computer processing of images is that the images be available in digital form, that is, as arrays of finite length binary words [54]. For digitization, the given image is sampled or pixel is quantized using a finite number of bits. The digitized image can then be processed by the computer.

Light is an obvious form of energy transmitted in some way through space [55]. It is a matter of common experience that objects can be seen only in the presence of light. In general, visible light can be defined as that form of energy which affects the eye so as to produce the sensation of vision. Objects are anything that light hits [56].

Polished diamonds rely on light for their beauty. Light brings together the inherent properties of diamond, the optical effects created by faceting, and the observer's ability to appreciate the gemstone. The best way of studying or examining a diamond is by viewing it in the natural light, that is, sunlight. But sunlight is subject to change from time to time. Different illumination conditions and surroundings (the viewing "panorama") can enhance or diminish the appearance of fire. Polished diamonds look different in office lighting, candlelight, or outside on a sunny day. This is because of differences in the viewing environment. In this case, the environment includes not only the type of lighting that is illuminating the diamond, but also the surroundings (such as walls, ceiling, floor coloring, and other objects in the immediate area) in which the diamond is viewed. All of these variables can be classified under the heading of viewing panorama. An important distinction between typical office lighting and candlelight (or sunlight) is the spread of directions from which the light beams enter the diamond. Office lighting (often fluorescent lighting that bounces off white ceilings and light-colored walls) is considered a type of diffused lighting. In completely diffused lighting, light strikes the diamond evenly.
from everywhere and from all angles. Although this type of lighting may highlight the brightness of a polished diamond, the more evenly diffused it is, the more it will suppress fire. Candlelight or sunlight is the opposite of diffused lighting and is called directional lighting or spot lighting. In spot lighting, light strikes the diamond from one or more single point sources which are small and bright compared to the areas around them. The contrast between the light and dark areas in spot lighting, along with the contrast due to the edges of the diamond facets, bring out the fire in a diamond. Edges between light and dark in the panorama also have an important effect on fire. Separate rays of colored light can recombine into white light when they overlap. In diffused lighting, because the light enters evenly from all angles, there are usually enough wavelengths of all colors to add up to white (or mostly white) light coming from the diamond (ignoring the color of the diamond itself). In spot lighting, the spread of colors that becomes apparent on the edges of the light beam is not recombined into white light, because there are no other light beams right next to them. Therefore, these wavelengths (colors) remain separated and are seen by an observer as fire. Figure 2.1 shows an example of this. On the left (figure 2.1(a)) is a photograph of a diamond taken in very diffused lighting, and on the right (figure 2.1(b)) is the same diamond photographed in spot lighting.

![Figure 2.1 The same diamond in diffused lighting (left 2.1 (a)) and spot lighting (right 2.1 (b)). [24]](image)

Although diffused lighting suppresses most fire in polished diamonds, there are situations in which chromatic flares (color flashes) may still be seen. These also have to do with contrast in the panorama, but in this case the contrast is a result of objects surrounding the diamond. These objects include the observer. (Examples of
objects that may cause contrast in a diamond’s panorama are dark bookshelves against light walls, and dark clothing against light clothing or light backgrounds.) The flashes of fire from these influences in the panorama are much more subtle than those from spot lighting, since the intensity of the light is much less. Figure 2.2 shows a close-up photograph of a diamond. It is possible to see a blue flash of color even though the photo was taken in diffused lighting and there was nothing blue in the diamond’s panorama.

![Figure 2.2 A chromatic flare in diffused lighting.](image)

This flash of color was due to the observer wearing a black suit while standing against a white background — as this contrasting edge is dispersed through the diamond, a colored patch results. A last consideration regarding dispersion and fire in polished diamonds is that flashes of color will only be observed if the viewer’s eye is in the path of the colored light beam. Chromatic flares are somewhat narrow beams of light that emanate from the diamond. There are many gaps between these flares. Observers will see a bright flare if it is directed at their eye, but will see faint color or no color if their eye is between the flares (figure 2.3). An observer’s eye can only view the flares that are in its direct line-of-sight. So, an observer has to be in the right position to see fire. This is why different chromatic flares can be seen when an observer tilts a diamond. Because the observer cannot be in all positions above the diamond at once, it is not solely the amount of fire (number or intensity of chromatic flares) that is important, but also the direction in which those chromatic flares escape from the diamond.
2.2 Need for Scanners to acquire the images of diamonds

In the present work conventional as well as digital camera was not used as a device for image acquisition, due to the need for identical conditions to prevail while acquiring the images of diamonds. One of the most common problems is the out of focus picture. There are many reasons why a picture might be fuzzy. The subject or the photographer might have moved slightly. Perhaps the camera wasn’t focused correctly. Or possibly the picture was taken with an inexpensive camera with a poor quality plastic lens. Scanners are much like photocopying machines [57]. Scanners are commonly available to convert photographs to digital images [58]. They work by making a bit-by-bit image of any document, photograph, or piece of artwork fed into them. It is possible to import a scanned document into Photoshop and work on it just like working on a digital photo. Generally, scanners are used for digitizing photos and other flat paper documents, but they can also be used to scan real 3D objects [59]. Diamonds are three-dimensional objects [60]. The three dimensions are height, width, and depth. Hence, a flatbed scanner HP Scanjet 2300c has been used for image capturing in the present work as it helps in maintaining consistency in terms of lighting conditions, intensity of light, amount of illumination, distance between the object and the light source, each time a diamond is scanned. The diamond is directly placed on the scanner’s glass. There is no other intervening object between the source of light and the diamond. Light escaping from inside as well as the entering of light

Figure 2.3 Different color flares will be seen, depending on the direction that the flares exit the diamond, and where the observer is located. [24]
from outside can also be blocked. As the diamonds vary in size in millimeters they can be scaled to about ten times their original size using the scanner. The image of an original diamond acquired using the scanner is shown in figure 2.4. This figure makes it possible to find out that the original diamond whose image was captured has a large culet that is visible to the eye as a hole in the centre.

![Figure 2.4 Image of an original diamond acquired using HP Scanjet 2300c.](image)

Scanners enable to digitize photographs, fabric, tiles, and other flat materials for use as textures. Scanners come in many sizes and configurations, but there are three main types for desktop use: handheld, flatbed, and slide scanners. Flatbed scanners are the most popular type, and consist of a case with a glass top and cover. Images are placed onto the glass and held in place by the cover while the scanner’s in operation [61]. The environmental specifications for the scanner HP Scanjet 2300c are shown in table 2.1 and the scanner specifications are shown in table 2.2.

| Temperature | Operating: 10 to 35 degrees Celsius (50 to 95 degrees Fahrenheit)  
| Storage: -40 to 60 degrees Celsius (-40 to 140 degrees Fahrenheit) |
| Humidity | Operating: 15 to 80 percent noncondensing  
| 10 to 35 degrees Celsius (50 to 95 degrees Fahrenheit)  
| Storage: up to 90 percent  
| 0 to 60 degrees Celsius or (32 to 140 degrees Fahrenheit) |

Table 2.1 Environmental specifications for the scanner [62].
<table>
<thead>
<tr>
<th>Scanner type</th>
<th>Flatbed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weight</td>
<td>1.72 kg (3.79 pounds)</td>
</tr>
<tr>
<td>Weight of document lid</td>
<td>0.28 kg (0.57 pounds)</td>
</tr>
<tr>
<td>Maximum item size</td>
<td>458 x 275 x 62 mm (18.0 x 10.8 x 2.4 inches)</td>
</tr>
<tr>
<td>Scanning element</td>
<td>Charged-coupled device</td>
</tr>
<tr>
<td>Interface</td>
<td>USB</td>
</tr>
<tr>
<td>Optical resolution</td>
<td>600 dpi</td>
</tr>
<tr>
<td>Bit depth</td>
<td>48 bit color</td>
</tr>
<tr>
<td></td>
<td>16 bit grayscale</td>
</tr>
<tr>
<td>Image processing (options)</td>
<td>Dithering, thresholding, scaling, interpolation, gamma adjustment, matrix adjustment</td>
</tr>
<tr>
<td>AC line voltage</td>
<td>100-120 V 60 Hz North America</td>
</tr>
<tr>
<td></td>
<td>200-240 V 50 Hz Continental Europe, United Kingdom, Australia</td>
</tr>
<tr>
<td></td>
<td>100-240 V 50 Hz/60 Hz rest of world</td>
</tr>
<tr>
<td>Power consumption</td>
<td>For power consumption data, see the regulatory_supplement.htm file on the CD-ROM that came with your scanner.</td>
</tr>
<tr>
<td></td>
<td>All scanner series are ENERGY STAR compliant. (ENERGY STAR® is a U.S. registered service mark of the United States Environmental Protection Agency.) As an ENERGY STAR Partner, Hewlett-Packard Company has determined that this product meets the ENERGY STAR guidelines for energy efficiency.</td>
</tr>
</tbody>
</table>

Table 2.2 Scanner specifications for the HP Scanjet 2300c [62].
2.3 Image acquisition using Scanner

The images of the original as well as artificial diamonds are obtained using the scanner. First, the diamonds are placed on the scanner's glass and scanned using Import Command in Adobe Photoshop as shown in figure 2.5.

![Import Command in Adobe Photoshop](image)

Figure 2.5 File > Import > HP Scanjet 2300c

Every diamond is scanned in three different views:

1. Table view
2. Pavilion view
3. Culet view

If photos or flat paper documents are scanned, the scanner remains closed completely by the lid, so that there is no possibility for the light to either escape from inside or to enter into the scanning process from outside. But when three-dimensional objects like diamonds are placed on the scanner's glass, the lid cannot be closed completely, even if the stone is of very small size. In such a case, there is a chance for the light from inside to escape, and light from outside to enter the scanning process through the minute opening, which might introduce unwanted flash like effect or appearance on the image. For obtaining a good quality image, the object (diamond) is first placed on the scanner's glass, the lid is closed, and this lid is covered...
externally with white cloth to reflect light better, and again a black cloth is placed over the white cloth to prevent light from escaping [59].

For obtaining images of the table view and pavilion view, before closing the lid over the object on the scanner’s glass, for want of maintaining the object’s position and alignments on the glass, a small circular cover of approximately one inch height and three inch diameter with ordinary glass on its top was placed over it. The extent to which the glass in this small cover will have influence on the quality of the object’s image need not be considered, because such images are used only to find out the size related aspects, and not for any qualitative analysis.

For the purpose of distinguishing original from artificial diamond, only culet view images are used, for which the diamond is made to stand on culet using the scanner’s cover directly. After placing the diamond on the scanner’s glass and closing the lid, the command File > Import > HP Scanjet 2300c is used to acquire the image. But as the diamonds are of very small size, the image is scaled up to 1000% that is, nearly ten times the original size of the image. All images are acquired with resolution 200. After accepting the image into Photoshop, only 3 x 3 area (in inches) consisting of the object’s image is cropped and saved using the command File > Save As with a filename. Figure 2.6 shows the scanning process.

The entire process is explained in a step-by-step manner and is shown below:

1. Place the diamond on the scanner allowing its table / pavilion / culet to be in contact with the scanner’s glass for acquiring the table view / pavilion view / culet view image.

2. Place a small cover over the diamond to maintain its alignment and position on the scanner’s glass (only while acquiring table view and pavilion view images).

3. Close the lid of the scanner.

4. Scan the image using the command File > Import > HP Scanjet 2300c in Photoshop.

5. See the preview. Select 1 x 1 area (in inches) containing the diamond, that is, set the selection area dimensions as width = 1 inch and height = 1 inch.

6. Resize the object from its original size (100%) to ten times its original size (1000%), that is, set the output dimensions as width = 10 inches and height = 10 inches.
7. Set the resolution to be 200.
8. By clicking Accept, the image is scanned into Photoshop.
9. Using rectangular marquee tool crop the image with width = 3 inches and height = 3 inches, containing the image of the scanned diamond.
10. Save the file using the command File > Save As > filename.psd as a Photoshop file.

2.4 The .psd file format

The format used for saving is the native file format of Photoshop, that is, .psd. Photoshop supports a number of file formats, the list of formats is shown in figure 2.7.
Using a compressed format means choosing a file format such as TIFF with LZW (named for its inventors; Lempel, Ziv, and Welch) compression, which automatically shrinks the file down as small as possible when it saves. It does this by a means called "lossless" compression, so there’s no image degradation or blotchy color. LZW compression is also used by GIF (Graphics Interchange Format), PDF (Portable Document Format), and PostScript formats [57]. There are also formats, such as JPEG (Joint Photographic Experts Group), which use "lossy" compression. This means that some of the data that makes up the image is lost in the compression process. Instead of 20 shades of blue in the sky in a TIFF (Tagged-Image File Format) file, the same image in a JPEG file might have only five shades of blue. Unfortunately, compression is necessary when putting images on the web or into a multimedia presentation, or in some other situation where upload time or storage space are limited. JPEG saves files in the smallest possible form. The most common file format in Photoshop is .psd, which is the native Photoshop file format (Photoshop document). Every file format has its own advantages and disadvantages. .psd files are large in size, but it is the only file format that can save the layers and make further processing easy, whereas other formats require merging the layers into one before saving. For this purpose .psd file format was used for saving the scanned images, in the present work.

The line drawings for table view, pavilion view and culet view images of diamonds are shown in figures 2.8(a), 2.9(a) and 2.10(a) respectively, with AB representing the plane of the scanner’s glass.
The images shown in figures 2.8 (b), 2.9 (b) and 2.10 (b) represent the table view, pavilion view and culet view images (scanned images) of the same original diamond of weight 18 points, or 0.18 carats.

2.5 Digital Image Processing techniques used in the present work

The present work was done using Compaq model P6125, Pentium IV 1.7 GHz Processor, 256 MB RAM, 40 GB Hard Disk, DVD Drive16X, 1.44 MB Floppy Drive, Multimedia Keyboard, Compaq Monitor Model MV5500, 15 Inch Digital Color Monitor with JBL Speaker and HP Scanjet 2300C.

Adobe Photoshop is a powerful image-editing program that allows editing and colorizing images, retouching proofs, creating original or composite artwork and producing prepress color separations. Photoshop works with bitmapped, digitized images.

Features of Adobe Photoshop used in the present work are described below.

The usage of elliptical marquee tool is explained in Chapter 3. The significance of thresholding and histogram is discussed in detail in Chapter 4. The application of magic wand tool is discussed in Chapter 6.
Filters in Photoshop

The built-in filters are grouped into 14 submenus. In addition, any third-party filters installed appear at the bottom of the Filter menu [63]. The Filter menu is shown in figure 2.11.

Out of these filters only five have been used in the present work. They are stated below.

Filter > Sharpen > Sharpen Edges
Filter > Stylize > Find Edges
Filter > Stylize > Emboss
Filter > Brush Strokes > Accented Edges
Filter > Blur > Smart Blur.

Sharpening filters

PHOTOSHOP can create the illusion of sharper focus. It does this with a set of filters called Sharpen. The Sharpen filters focus blurry images by increasing the contrast of adjacent pixels. Sharpen Edges doesn’t affect the whole image, but sees and enhances the contrast at whatever it perceives to be an edge. Sharpen Edges filter in Photoshop finds the areas in the image where significant color changes occur and sharpen them. The Sharpen Edges filter sharpens only edges while preserving the overall smoothness of the image. These filters sharpen the edges of an
image without sharpening the interior detail [64]. A new filter named D-Filter (Diamond Filter) has been devised and used as a sharpness filter that helps in the identification of inclusions. Filter > Other > Custom is followed and the following matrix is used. The resulting filter is named D-Filter which is explained in detail in Chapter 6.

\[
\begin{array}{ccc}
-1 & -1 & 1 \\
-1 & 5 & 1 \\
-1 & -1 & -1 \\
\end{array}
\]

Find Edges Filter

The Stylize filters produce a painted or impressionistic effect on a selection by displacing pixels and by finding and heightening contrast in an image. After using filters like Find Edges that highlight edges, the Invert command can be used to outline the edges of a color image with colored lines or to outline the edges of a grayscale image with white lines. The Find Edges filter identifies the areas of the image with significant transitions and emphasizes the edges. It also outlines the edges of an image with dark lines against a white background and is useful for creating a border around an image. The Find Edges Filter emphasizes the edges and is useful for creating borders as well [65].

Emboss Filter

The Emboss filter makes a selection appear raised or stamped by converting its fill color to gray and tracing the edges with the original fill color. Options include an embossing angle (from -360° to lower (stamp) the surface, to +360° to raise the surface), height, and a percentage (1% to 500%) for the amount of color within the selection.

Blur Filters

Blur filters soften a selection or an image. They are useful for retouching. They smooth transitions by averaging the pixels next to the hard edges of defined lines and shaded areas in an image. The Smart Blur precisely blurs an image. It is possible to specify a radius, to determine how far the filter searches for dissimilar pixels to blur; a threshold, to determine how different the pixels' values should be before they are eliminated; and a blur quality and also to set a mode for the entire selection (Normal), or for the edges of color transitions (Edge Only and Overlay).
Where significant contrast occurs, Edge Only applies black-and-white edges, and Overlay Edge applies white.

The Smart Blur Filter is probably the most useful one of the bunch, especially for image editing and photo repair. It blurs everything in the image, or selection, except the edges. Smart Blur calculates the differences between color regions to determine boundaries, and it maintains these boundaries while blurring everything within them. It smoothes out grain and noise patterns between edges without adversely affecting image sharpness or fine detail [66].

The Smart Blur Filter has the following three modes.

- Normal mode: The preview window shows the effects of the blurring.
- Edge Only: Shows the outlines that Smart Blur is working with.
- Edge Overlay: Shows the outlines as black lines on top of the image.

Smart blur allows creating line drawings. The number of lines can be determined by setting a threshold, or a value that determines what differences in colors will give us a line. 100% difference is like black and white so where black and white meet, a line will be got. The radius will tell the program how far away the color differences are measured. The radius and Threshold can be set to determine how much blur is applied, and also the Quality, to determine how the effect is calculated. The value of Radius, Threshold, Quality and Mode chosen for the present work are 100, 100, high and Edge only respectively.

Brush Stroke filters

The Brush Stroke filters give a painterly or fine-arts look using different brush and ink stroke effects. Some of the filters add grain, paint, noise, edge detail, or texture to an image for a pointillist effect. Accented Edges accentuates the edges of an image. When the edge brightness control is set to a high value, the accents resemble white chalk; when set to a low value, the accents resemble black ink. In other words, the Accented Edges Filter outlines the edges of the image. When the brightness is set to a high value, it appears to be outlined in a light-colored chalk. When the brightness is set to a low value, it appears to be outlined in dark ink [67].

The Accented Edges dialog box enables to choose edge width, edge brightness, and smoothness. The edge width, edge brightness and smoothness values are chosen to be 2, 5 and 5 respectively.
2.6 Conclusion

As it was stated in Chapter 1, the most commonly used Gem testing instruments are the 10X loupe and the microscope. The most commonly used equipments for image acquisition are the conventional and the digital camera. The aim of the present work is to facilitate even a layman to examine his diamond by himself, by using his own computer. The usage of loupe, microscope, conventional or digital camera, provide only a physical and inconsistent means to identify original diamonds from Cubic Zirconia. Hence, to maintain consistency, scanner has been used for diamond image acquisition, so as to provide a systematic approach, and the result has been found successful. The images acquired using the scanner are further processed using digital image processing techniques as described in chapters 3, 4, and 5 for the identification of original diamonds from Cubic Zirconia, and in chapter 6 for the study of inclusions.